upstox pro in web - connection lost - re connecting - frequent delays / lags in screen

I face this problem often in upstox pro in web - connection lost - re connecting - frequent delays / lags in screen
I normally get this issue only during market hours, till 3-15 pm approx.
I have latest laptop with high configuration, windows 11 latest updates, paid virus protection.
I have 150 MBPS broadband connection.

I created a support ticket and they asked me to clear cache and try again, even after doing this, I get this.

I have zerodha and icicidirect and I do not face any lag in any of these accounts.
I feel this is related to load in server side of upstox. Is there anyone who also face similar issue and what is the resolution.
Please update or escalate.

1 Like

I have the same issues going on.

I have raised tickets and they are asking me to clear browser cache and etc.

First of all, I am very well versed with the cache and all, so I have enabled “Clear Cache and History” by default whenever I open my browser.

I use Airtel Fibre with Mesh router at 200 mbps with a ping of 5ms.

I trade on a MacBook Pro Top Spec Variant.

AND STILL I AM FACING ISSUES! So it’s not my fault.

I specifically trade using and facing “order getting stuck” issues. The order gets stuck in the middle anywhere.

Happened today in the morning as well.

I really didn’t want to post it here but the issue is not getting resolved by talking to customer care or speaking to the head of the customer care office.

I have marked my Ticket ID #7617427 as resolved as I really can’t scratch my head to explain this issue. So attaching a GIF from a screen grab in the morning.

Maybe someone from the engineering team needs to look at it.

In the screen grab, I am pressing the “Cross” Button to cancel and it doesn’t get cancelled. Any Modification makes it stuck. So I use “CMD+R” to refresh and then cancel.

Screen Recording 2023-05-26 at 9.16.15 AM


I am Sorry to raise a bug here as this is not a platform to talk about bugs.

I believe raising this issue through customer service is not making this glitch reach the right people.

I have been trading in TV Libraries to trade using “Instant Order Placement” feature for 2 years and this glitch has happened with other brokers as well in the early stages of their TV Library adaptation. It needs optimisation for this Instant Order Placement feature.

I guess this issue is happening only because of some underlying problem in the app where it is not able to sync in realtime milliseconds during volatility.

My purpose to use Upstox is to experience the fantastic new design, Manage order & positions with ease by using it’s app and a trustworthy infrastructure with stable connection. However, this small glitch is causing a lil bit of trouble during volatility.

I hope this post can reach the right people and then can be deleted if bugs are not to be discussed here.

I really appreciate any help from your side on this matter!

Thanks for reaching out about this and I definitely understand that this isn’t a great experience for either of these issues.

@SKR - do you have the support ticket number and is it OK if we schedule a time to call? The initial diagnosis from the team is that this usually happens when there is a drop in internet connectivity or the connection is unstable. However, since you reference other brokers (and @11.11 has this issue as well), this may be another issue.

@11.11 - Thanks for the animated GIF…that helps. I’ve asked our Tech team to look into this and try to reproduce this TV problem.

1 Like

@mike Thank you for the response and taking it to the tech team! :blush::heart:

I really love the new face of Upstox! The new layout for Options Strategies is excellent!

To be honest, Upstox’s TV Library has been a very stable library during the initial implementation! I am sure as time passes, it will be more optimised! I understand the drawbacks of a third party library. It’s really not easy. :sweat_smile:

Also to mention, I would like to appreciate the whole Upstox team for an amazing revamp! I have been using Upstox from very long and I am really happy to see where Upstox is heading!

@11.11 – Appreciate the kind words as the tech / design / product teams have spent a great deal of time and effort to improve the end-to-end experience. Of course, we know that there are still always opportunities for improvement. Please feel free to let us know of your concerns or insights into the platform so we can stay on top of them.

I do not have the support ticket number, rather it is difficult to find this in upstox. I searched my email and have got reply from upstox support on april 14th to send screen grabs…

Its happening quite often and really frustrating and planning to reduce activity in upstox and move away to other broker platform… as not much help from support.

@SKR - I just DM’d you about this.

It happens during high volatility mostly everyday. Today it happened for the first 20-25 mins and after the market cooled down post initial profit booking, it became fine. However in normal trading hours too, It glitches out sometimes.

I haven’t noticed any loss of connection yet @SKR. The connection seems to be fine.

I am mostly using so I believe there is a lag on order placement during high volatility only which causes my order button to get stuck. It can also be because of a connection lost or reconnection which causes this order button to get stuck.

To point out, it happens during high volatility mostly.

I have spoken to the customer care and I am sure Upstox tech team will optimise it further!

Screen Recording 2023-05-29 at 12.05.25 PM

When markets are cooled down, this button works flawlessly smooth! I want tech team to optimise it like this for high volatility too!

I know it’s a very difficult task as this order management system is built on a third party library which has limited controls. I believe Upstox has a capable team to optimise this for volatility!

Thanks for taking the time to give some additional context. That’s very interesting. Let me send this over to the tech team and see what they say about it. Again, I really appreciate this!

1 Like

@11.11 We have resolved this issue. Earlier for placing an order from the charts, we used to rely on the API response and we weren’t getting an updated API response all the time. We have since then implemented web-socket to fix this. Kindly check at your end by logging into and let us know if the issue still persists.

As always, thanks for your support!

1 Like


Thanks a ton for this fix!! Yes, it’s working butter smooth now! Exactly how I wanted!!

The button has become super responsive now! I trade using mostly.

I really appreciate this fix! :green_heart:

1 Like

Hey @vivekchoksi

Yesterday it was working flawless!

Today Morning as well during high volatility, it had near 1 second delay for the first 2 minutes but was manageable and was working fine.

Just now, it has started getting stuck at any random time. I have been purposely placing ghost orders to test the button.

I am not sure why this problem happens only sometimes and only in “Instant Order Placement” feature. Without this feature turned on, the button has no problems.

A screen grab from around 9:46AM today.

Screen Recording 2023-06-13 at 9.46.51 AM

Hey @11.11 thanks fo raising this. Allow me some time and let me talk to my tech team right away.

1 Like


There is something that is causing this issue. Yesterday it had zero issues and was butter smooth.

The order is taking time to modify as well now without “Instant Order Placement”

Please see that this issue is only seldom. Maybe 1 in 7 orders if placed within 1 minute.

Screen Recording 2023-06-13 at 10.02.05 AM

To confirm, my Internet speed is also fine.

Screen Recording 2023-06-13 at 10.03.57 AM

It may not be happening now. I am not sure tough. @vivekchoksi

It is only at some random time. That random time can come at any time of the day.

After few minutes of posting this, it is working fine as of now. Maybe something affects it sometimes which causes that button getting stuck problem.

I am not able to figure out the exact cause. It’s not internet issue as instant refresh makes it work. Cannot be cache or history as I have set it to clear on every exit. Maybe your tech team will figure out the root cause precisely!

Well, the best part is that the refresh rate is Instant! So even if this happens, the instant refresh can help to manage the open order/position.

As long as browser is concerned, I have tested TV library on every browser and it works the best on Brave Browser which also based on Chromium. The Brave Browser’s engine makes it works the fastest. That’s why it is preferred by Crypto traders as well.

Although, if this button can be optimised without this lil error, it will be a delight for fast scalpers!

Just to share, I use in a small window like this and split it via the tile mode on Mac.

I test the button in this manner sometimes to check.

Screen Recording 2023-06-13 at 10.58.05 AM


Hey! The issue happens during volatility, mostly when I guess people are placing large orders. Like this Intraday Momentum Breakout caused it to glitch. I had my screen recorder handy. A refresh using CMD+R brings it back to the OG position so that I can cancel it or modify it.

I am also attaching the order number so that you can check the backend.

Screen Recording 2023-06-15 at 9.52.14 AM

Order Details

I look for such price actions a lot and don’t wanna miss anything during this period. I can give up taking a position to record this so that your team can know this and it can be fixed.

@mike @vivekchoksi

I am sharing another Screen Grab alongside Pro Upstox. I don’t keep open but as this is happening today, I decided to open and show the sync as well.

I have missed the price action as this glitch kills my confidence. I get scared for a while. I am not sharing this with support but here so your team can collectively look at this issue.

My purpose of posting this is just to help Upstox improve this. Hence, I am recording my screen rather than trading as a fix will be beneficial for me in the long run.

Screen Recording 2023-06-15 at 10.25.34 AM

Here you can see, when fails to modify, it doesn’t get modified on too.

The moment after refresh when the button gets fine, it syncs with
@mike @vivekchoksi

Update: I had a call with some people from Upstox yesterday.

First of all, I really appreciate the professional support! They were very helpful and were ready to understand the problem.

I have tried the button today and it’s working very smoothly. I don’t know if they have fixed it or its because of less number or order frequency today but it’s working smooth.

Screen Recording 2023-06-16 at 12.04.06 PM

Incase I face this problem again, I will raise it here.

Together, we as a Community can make Upstox the best!!!

1 Like

Thanks for your constant support @11.11 Appreciate it!