Portfolio stream data websocket not working

I have tried this example https://github.com/upstox/upstox-nodejs/blob/master/examples/websocket/order_updates/websocket_client.js and it’s getting stuck after connecting to the websocket. no data is being returned by the socket. is there something I am missing?

Based on the screenshot you’ve shared, it appears that your websocket is successfully connected and is awaiting order updates. Have you attempted to place an order through https://pro.upstox.com?

I’ve conducted another verification using the example guide available at

It’s working correctly for me, as I am receiving updates on the order.

Yeah, I already had the positions at that time. but the socket was not sending the data. I think there are some issues. I tried again and nothing came. btw I am trying to achieve P&L of my current positions.

It seems you’re inquiring about position updates. Currently, position information is not yet transmitted via the websocket. At present, the websocket only provides updates on changes in order status.

As for the updates on positions, this is currently under discussion with the concerned team. I will inform you once a decision is made to proceed with it.