Getting UDAPI100016 after changing Base URL from https://api-v2.upstox.com to https://api.upstox.com/v2

Hi Upstox Team,

After switching to the new Base URL (from https://api-v2.upstox.com to https://api.upstox.com/v2)
I am unable to login and generate a new token.

getting following error after providing my “Enter 6-digit PIN” on upstox login screen.

{“status”:“error”,“errors”:[{“errorCode”:“UDAPI100016”,“message”:“Invalid Credentials”,“propertyPath”:null,“invalidValue”:null,“error_code”:“UDAPI100016”,“property_path”:null,“invalid_value”:null}]}

Please Help.

Thanks

@CE5464,

Thank you for informing us about your concern.

I am currently looking into it and will get back to you shortly.

Thank you!

@CE5464,

In reference to your account, the latest logs I have access to indicate that as of December 5th, the last recorded activity was a successful market data websocket connection.

Could you confirm if the authorization issue you mentioned is still occurring?

If it persists, I would appreciate it if you could attempt the process once more and inform me of the outcome.

Thanks!

Hi @shanmu
Actually on 5th october also I faced similar issue with the new Base URL, but after getting the above issue, I crossed checked my code with old URL. and from older URL i was able to generate the token.

So the market data websocket connection was established using the old URL.

@CE5464

Could you please attempt to authenticate once more using the provided new URL? Let us know the specific time when you do this, so we can appropriately filter the activity logs.

Thank you!

Hi @shanmu,

Tried to login now at 11:36 AM

still getting the same error:-

{“status”:“error”,“errors”:[{“errorCode”:“UDAPI100016”,“message”:“Invalid Credentials”,“propertyPath”:null,“invalidValue”:null,“error_code”:“UDAPI100016”,“property_path”:null,“invalid_value”:null}]}

@CE5464,

I’ve sent you a direct message regarding this matter, as it may require a more in-depth discussion or a direct connection.

Thank you!

@CE5464

We’ve resolved the issue on our end. Please try again and inform us if it’s working for you now.

Thanks!